Application Slowness
Incident Report for Edge Delta
Resolved
This incident has been resolved.
Posted Apr 04, 2024 - 20:33 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 04, 2024 - 20:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2024 - 20:21 UTC
Investigating
A slowdown in EdgeDelta UI performance has been reported. An investigation is currently in progress.
Posted Apr 04, 2024 - 19:43 UTC
This incident affected: Web UI.