New Account Sign-up Issue
Incident Report for Edge Delta
Resolved
The sign-ups process for new accounts are confirmed.
Posted Dec 21, 2022 - 21:36 UTC
Monitoring
A fix enabling new user sign-ups has been implemented and we are now monitoring to assure service.
Posted Dec 21, 2022 - 20:45 UTC
Identified
The issue preventing new account sign-ups has been identified and a fix is being rolled out.
Posted Dec 20, 2022 - 19:32 UTC
Investigating
New account sign-ups to the The EdgeDelta service are currently not being completed. We are working to identify the root cause and restore the service as soon as possible.
Posted Dec 19, 2022 - 20:30 UTC
This incident affected: Web UI.